Lessonl

Make View: Create a Survey

SUMMARY

This lesson is an introduction to the Make View module of Epi Info™. During this lesson,
you will create your project MDB and create an electronic version of a survey used to collect
data from students in the county.

In order to develop data that can be used to show the need for funds, you must first develop
the survey that will act as your primary data collection instrument. In this example, the survey
has been developed for you and is attached as Appendix B: Parent School Asthma Pre-
Intervention Survey. Lesson 1 guides you through the process of using Make View to create
the survey. At the end of this lesson, you will have experience using the Field Definition
dialog box to make many of the fields needed to collect data from the survey population.

Time to complete: 1.5 hours Beginner
Getting Started with Make View

Overview of basic information to navigate Make View and understand Project creation.
Describes how to use the Field Definition dialog box.

Create Fields, Part 1

Begin using the Field Definition dialog box to create text, date, numeric, and Legal Value
fields. Learn how to set the tab order and name a page inside your Project. Includes a Practice
lesson.

Formatting Options

Learn how to format your workspace by changing erid settings or the background color.
Learn how to format/edit fields in your view by tesizing or aligning fields.

Create Fields, Part 2
Learn how to create a checkbox, group, mitror, and yes/no field. Includes a Practice lesson.
Skills Review

Hands-on series of tasks with fewer instructions and a greater degree of difficulty. Learn how
to create a comment legal field.

BEFORE YOU BEGIN

Install the latest version of Epi Info™ on your computer.
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Complete the File Set-Up section of the tutorial.

WHAT YOU NEED

Appendix A: Code Sheet

Appendix B: Parent School Asthma Pre-Intervention Survey

FIVE GOALS

= Create a project called AsthmaSurvey and a View called PrelnterventionSurvey.
®  Create three pages in a View to hold survey questions.

®  Create a Requited StudentID field/vatiable to track students.

*  Create Date of Birth and Age fields/vatiables to track student ages.

= Set the Tab Order to verify the data entry order the cursor needs to follow.
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Getting Started with Make View

Epi Info™ uses the Microsoft Access data format to create Projects, files, or MDBs. Each
Project contains a View and a Data Table. The View contains information about the screen
appearance, or how the survey looks, and how data is entered into the data table. For example,
you will create a View based on the Asthma Pre-Intervention Survey. The View will be a re-
creation of the paper survey along with information about field names, field types, and Check
Code.

The View and the data table live inside your Project or MDB. There can be up to 1,000 views
inside your project. Each view can contain 255 fields. Each field can contain 128 characters.
When you enter data in the Enter module, you will be entering data into your MDB. The data
table contains the actual values associated with your Project or MDB.

The Make View program is used to place prompts and data entry fields on one or many pages
of a View. Since this process also defines the database(s) that are created, MakeView can be
regarded as both the form designer and the database design environment.

Inside each View you will create fields (called variables in Analysis) to hold your data. Variables
can be stored on many pages inside a View. You can use the Program Editor component of
Make View to add Check Code to your variables. Check Code represents a series of rules
applied to your data. One example, used in the tutorial, concerns the calculation of date fields.
You can create Check Code stating that when a date of birth is entered in one field, the age of
an individual is automatically calculated and placed in another field. This allows you to
customize your questionnaire and makes data entry quicker and more accurate.

A Project or MDB
contains all the files that
make up your data table.

The Data Tables contain

TABLE 1 TABLE 2 the fields you create in
Make View and the data
VIEW 1 VIEW 2 from Enter Data. Tables

contain the data used for
Analysis.

PAGE 1 PAGE 3

The View is where you

: will design your survey.
Field5 [ ] There can be up to

! 1,000 Views inside a
Field 6 D Project. Views hoid your
pages and fields.

Pages denote sections
of new information just
as on a paper form.
Views can hold many

pages.

Fields are placed in
pages and become the
variables used for
Analysis after you Enter
your data.

Database Organization Chart
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The Make View Workspace

1. From your desktop, double click the Epi Info™ icon | to open the program.

2. Click Make View or select Programs>Make View (Questionnaire) to open the Make
View module. The Make/Edit View window opens.

3. As you read this Overview, use your mouse to view available tasks from the drop-down
menus.

= Menus will not be active until you create a new project in Lesson 1.

This is an example of the Make View workspace. The workspace settings are set to default;
meaning the background color is grey and the grid will be visible when you open a new file.

B oo | BEE

Fie Edt View [resrt Formst Took Help

Choose New or Open to begin

This iz an example of the Make /Edit View
window. This section iz called oue View. Onee
roucreate or opena file, Fou can begin adding
—ireg information to your View.

Thiz iz the Page Youwill aghtclick inside the View to brng up

MNames panel. Views the Field Definition dislog box and begin

can contain many working.

pages.

From the Page

Names panel, youcan

alzo accesz the

Program Editor

function of

MaksVigw and set up

voue Check Codes.

The field: created in Four view are the same az
thosein the paper Asthma Survey. When the
data entered in the feld: i importedinto
Amnalyziz, vou will zoctit by field name:, al=o
called Variables.

Navigating Make View
File Menu

Use the File menu to create a new project, open an existing project, save, COpy a view,
navigate to Enter Data, or exit the Make View program.

Edit Menu

Use the Edit menu to cut, copy, paste, move grid, delete a page, rename a page, select
a page, or change the tab order.
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View Menu

Use the View menu to navigate to the check commands screen where you can edit your
Check Code.

Insert Menu
Use the Insert menu to insert a new field, a new page, or create a group.
Format Menu

Use the Format menu to set a default font, align fields, change your background color,
or edit your settings. Setting a default font affects all text created by the Field Definition
dialog box after the selection. It will not affect fields created prior to selection. Settings
made to the default font can be altered by the Font for Prompt button in the Field
Definition dialog box.

Tools Menu

Use the Tools menu to import Epi 6 REC files, import Check Code, make a view from
a data table, create a data table, or delete a data table.

Make View Help Menu

The Help menu contains the help file contents, how to files, a command reference, and
the About Make View file.
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Create a Project

Now you will create the asthma survey/questionnaire. The information entered here will
populate your database and be used for analyses in a later lesson. Creating the survey requires
some forethought into the types of analyses you may want to run on your data. For example,
later you may want to see the Means of Age. To do this, you will need to have an age variable
in your survey, and the data must be entered into a Number field type. Think about what you
may want to know later and create your survey accordingly.

You are going to collect primary data to illustrate funding needs for an asthma initiative. To
start, you are going to re-create the Asthma Pre-Intervention Survey in an electronic format.

Refer to Appendix A: Code Sheet and Appendix B: Parent School Asthma Pre-Intervention
Survey as you create the survey.

You need to create a new project and a new view. Once inside the project, you can add pages
and create views to address all the survey questions. Later, you will enter records into the survey.

Be sure to place all your tutorial files in the EIHA Tutorial folder you created in File Set-Up.

1. From the Make View navigation menu, select File>New. The Create or Open
Project window opens.

2. Using the Look In drop menu, select your C drive.
3. Double click to open the Epi_Info folder.

4. Double click to open the EIHA Tutorial folder you created in the File Set-Up
section.

5. In the File Name field, type AsthmaSurvey.
6. Click Open. The Name the View dialog box opens.
7. Name the View PreluterventionSurvey.
* View names cannot have spaces or begin with numbers.
8. Click OK.

» The name of the window changes to Make/Edit View: PrelnterventionSurvey.
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The Field Definition Box

When you right click inside the View, anywhere inside the gray background area, the Field
Definition dialog box opens. This box is your main interface with the Make View module.
From here, you will create the fields where data will be entered into your survey and assign
names to the variables that make up your data table.

Use the Field Definition dialog box to:
* Enter a Question or Prompt. Use the tab key or your mouse to move from field to field.

=  Enter a Field Name. Field Names created in Make View are the Variable names used in
Analysis. No two Field Names can be the same.

= Select options for your field. For example, Read Only, creates a field that does not allow
for data entry.

®  Delete an existing field. Right click the text to open the Field Definition dialog box and
click Delete. To delete Legal Values and tables, open the associated table from the Field
Definition dialog box, and click Delete. There is no Undo button or verification prompt,
so be sure of your selection before choosing to delete vatiables or code tables.
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Field Definition x|

Question or Prompt

Enter the Question or Prompt in this field.
Ute the Font for Prompt button to overarrite
vour default fontand change the strle or =ize

;] Font for
LI Prompt

of text.
Field Names are the
—Field or Variable —Field Hame Tsﬁﬁﬁﬁ?m
fa tal . 111
Type | Text j Double click in prompt to char| Anslysis module, 7ou
| willuze these names
Size I j to work with rour
data.

The Field or Variable Trpe will set the type of

information entered for your Prompt. | Related View I

Based on the Trpe selected, Tou mar be given I
I-' Rﬂlm‘t the option to select a corresponding Pattern for —Code Tables

the entry. For exannle, if rou select Trpe as
|'_ Require| MNumber, Foucan celect 2 pattern for that Legal Values

mumber as F, 5%, #5%, ete. The Size Pattern
I_ Read Off deop-downchange: bazed on the Trpe of feld

zelected. Codes
[~ Sounde]

Field or Variable Trpes dictate how data will be Comment LBgﬂl
I_' Retain i entered and how it will be available for analyzes |

later.

oK Help

Field or Variable Types
From the Field or Variable type drop-down, you can create the following types of variables.
Click Cancel to close the Field Definition dialog box once you are familiar with the available

options.

Text

Creates a text data entry field. Letters or numbers can be entered in text fields. Text fields can
be sized for specific entries, or contain up to 128 characters. Can be used to create name or
address data entry fields.

Label/Title

Creates a title for the page or a label for a question. This field type is not searchable, not listed
in the tab order, and not visible for Check Code. Can be used to create a title in the view.

Text (Uppercase)
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Creates a text data entry field that can contain letters or numbers, but forces all text entries to
appear in uppercase only. Can be used to create a data entry field for state abbreviations or
identification fields that must use all caps.

Multiline

Creates a data entry field that can contain letters or numbers up to two gigabytes of information.
Can be used as a comments field or to enter long addresses.

Number

Creates a number data entry field based on a selected pattern, for example #, or ## H# H##.
Only numbers can be entered in the field. Can be used to enter identification numbers or ages.

PhoneNumber

Creates a phone number data entry field based on phone number patterns. Select from one of

two patterns, #HH-HH#HH or HHH-HHH-HHHH.
Date

Creates a date entry field based on a selection of patterns, for example MM-DD-YYYY or DD-
MM-YYYY. Dates entered must match the selected pattern. Can be used to enter today's date
or a date of birth.

Time

Creates a time entry field based on a selection of patterns, for example HH:MM:SS. Times
entered must match the selected pattern.

Date/Time
Creates a data entry field that contains both a Date and Time based on a selected pattern.
Checkbox

Creates a checkbox response. The Checkbox field is treated like a Yes/No field. When using
the Checkbox field, non-selected boxes do not appear as Missing in Analysis. Can be used with
Check All That Apply type questions.

Yes/No

Creates a Yes or No data entry field. Field will accept the typed word Yes or No. Yes/No fields
left blank will appear in Analysis with Missing values for those questions. The yes or no answer
is stored in the database as a 1 or 0. When creating Check Code use the (+) = Yes or (=) = No
to register a yes or no response.

Option
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Creates a radio button selection list. Use with Select One Answer Only questions. The Option
field is for mutually exclusive choices; only on choice can be made. If more than one choice is
needed, then use the Checkbox option.

Command Button

Creates links to other components or files. For example, you can incorporate an executable
button in the view to open Analysis or another program such as Microsoft Excel.

Image

Creates a placeholder to insert images into the view. Use an image field to insert an image per
record, for example, a patient, rash, or bacteria picture. The image file types that are accepted
are Graphics Interchange Format ((GIF), Joint Photographic Expert Group (JPG or .JPEG),
Windows Bitmap Format (BMP), Windows Icon File Format (ICO), Windows Metafile
Format (WMF), and Enhanced Metafile Format (EMF).

Mirror

Creates a field that appears on many pages. Mirror field types only work with multiple pages in
a single view. For example, if a Patient ID is on page one, the value of Patient ID can be echoed
onto another page using the mirror field. Mirror fields are read only.

Grid
Creates a related table/grid that can be inserted into a questionnaire or view to track specific
information, for example, a child’s measurements.

Relate

Creates relationships between your main view ("patent” view) with sub views ("child" views)
ONLY within the same .MDB. For example, link the general patient information to the
patient's record of visits.
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Create Fields Part 1

There are many types of entry fields that can be created in Make View. For this lesson, you will
create fields for Title, Text, Number, Date, and Legal Value.

Create a Label/Title Field

1. To create a field, right click in the Make View workspace. The Field Definition
dialog box opens.

2. In the Question or Prompt field, type the title of your survey.
»  Parent School Asthma Pre-Intervention Survey

*  The Question or Prompt box allows you to create a question that holds 128
characters. Entered text always appears centered.

3. From the Field or Vatiable Type drop-down menu, select Label/Title.
4. In the Field Name field, highlight the default field name, and type PreSurvey.

*= The Field Name will take part of the Question or Prompt and will
automatically create its own name. Because the Field Name cannot begin with
numbers, if a number is the first character in the Question or Prompt, a letter
will precede the rest of the Field Name.

= Notice that your Field Name is the same as your title. Field Names are created
automatically by Epi Info™ based on the data entered in the
Question/Prompt field.

= Field Names are also called Variable Names. Variable Names are used by the
Analysis module. Try to create names that will be easy to reference later in
Analysis.

» Field Names cannot have spaces in them.
=  Some applications that work with Epi Info™ cannot use field names longer
than eight characters. Keep this in mind if you will be using your data with

other statistical programs.

» Field Names cannot be changed once your data table is set in the Enter
module.

5. Click Font for Prompt. The Font dialog box opens

» The Font for Prompt button is used to change the font setting for the question
or prompt for the field.

6. Select a font from the list.

-11-
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7. Make the font Bold and size 14.
8. Click OK Your title text has been formatted with the new font type

» A Label/Title field cannot be used to create Check Code, cannot be searched,
nor is it included in the tab order list.

9. Click OK The title of your survey appears on the page.
= To move your title to the top center of the page, use the click and drag

technique. Select the text with your mouse, left click and hold while moving
the text to the desired location.
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# Practice

Add instructions to the survey.
Right click in your view to open the Field Definition box.

Create a Label/Title Field that states, "Please answer all the questions below, whether ot not
your child has asthma."

Give your variable the Field Name Instruction.
Make the font size for your instructions 12.
Move your instructions underneath the title.

Follow the same process to create Text type fields for the following:

Prompt/Question Variable | Field Name | Other
Type
School ID Number Text SchoolNum
Student ID Number Text StudentID Select Required option.
Zip Code Text Zip

Notice that you are making fields generally considered numeric into text fields. This is to ensure
that theses numbers will always appear as entered.

To restrict the number of characters that can be entered in a text field and thereby control the
data entry process further, you could select from the size drop-down located in the Field
Definition dialog box, and limit the number of characters allowed during data entry. When
thinking about form design, you would need to consider potential errors that could be made by
allowing typing into all fields. Creating I.egal Value drop-down boxes (covered later) are another
way of controlling data entry and limiting potential typing errors.

Page 1 of your View should look similar to this example:

M‘ (=] 3| - Make/Edit View: AsthmaSurvey

Add Page
Insert Page
Delete Page

[ Pogem |

-13-
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Create a Legal Value Field

When you create a Legal Value or Comment Legal field, you are creating a drop-down menu
within your view. Only selections from the drop-down menu will be accepted during data entry.
When creating a Legal Value field, the variable type must be Text.

The dataset contains a question about gender, which you are going to make a Legal Value field.
1. Open the Field Definition box.

2. In the Question/Prompt field, type Gender.

3. From the Variable Type drop-down, select Text.

4. Use the default Field Name, Gendet.

5. From inside the Field Definition dialog box, locate the Code Tables section.

—Code Tables

Legal Values

Codes

Comment Legal

6. Click Legal Values. The Set Up Code/Legal Links dialog box opens.
7. Click Create New. An entry box opens for your selected value.
8. In the first line, type Female and press Enter, then type Mal and press Enter.
9. Click the Do Not Sort checkbox.
= Make View sorts all Legal Values alphabetically, unless you select Do Not Sort.
10. Click OK to accept the Legal Values.
11. Click OK to accept definition entries.

= Notice your survey now contains a drop-down box with the values, Female and Male
as selections.

Create a Date Field

The Date field is a numeric field with pre-set date patterns that are selected from the pattern
drop-down menu.
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. To create a date field, right click in the Make View workspace. The Field Definition

dialog box opens.

In the Question/Prompt field, type Child’s Date of Birth.
From the Variable Type drop-down, select Date.

From the Pattern drop-down, select MM/DD/YYYY.
In the Field Name section, type DOB.

Select the Required option.

Click OK.

Create a Numeric Field

The Number field is a numeric value field that has six predefined value patterns. A new pattern
can be created by simply typing the pattern into the Pattern field.

Similar to Date Fields, selecting a Field type of Number gives you many Pattern selection
options. You need several types of number fields to complete the survey.

1.

2.

Open the Field Definition dialog box.

In the Question/Prompt field, type Age.

From the Variable Type drop-down, select Number.
From the Pattern drop-down, select ##.

Use the default Field Name, 4ge.

Select the Read Only option.

Click OK.

* In Lesson 2, you will create a Check Code to calculate this field, based on the
child's date of birth.

< Practice

-15-
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Create the Phone Number and PS School Number fields.

Hint: Phone Number is a new variable type.

Prompt/Question Variable Type | Field Name | Other

Home Phone Number PhoneNumber | Phone Select the Pattern
HAEH-HHH-HHHH

PS School Number Text PSNumber Select Read Only
option.
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Set the Tab Order

The tab order is set automatically based on the positioning of the fields in your View; however,
you can manually change the order of tabs in your survey. If you do not verify the tab order,
then your cursor may jump to fields out of sequence with data entry and cause errors.

You want to be sure that the order of fields matches the way information will be entered from
the paper survey. Refer to Appendix B to review the field order of the paper survey.

1. Click Edit>Order of Field Entry (Tab Order). The Order of Field Entry dialog
box opens.

intc Order of FieldEntry s - 5]
Page Controls:
TabIndex | Prompt Name Tab Stop

School ID Number SchoolNum | True
Student ID Number Studentld
Zip Code Zip
Gender Gender

Child's Date of Birth Up |

Age Age

Home Phone Number Phone True
PS School Number PSNumber Down |

oouml|.n-ww—t

2. Seclect the field order you would like to impose by selecting a prompt and then
using the up and down buttons.

= For example, the variable Age should come after the variable DOB.
3. Click OK to accept the new tab order.

4. C(lick File>Save.

-17-
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Name the page

If your survey contains more than one page, use the Page Names window to navigate pages. The
Page View Menu Panel displays the created Views' names and gives you access to created pages. You
can Add Pages, Insert Pages, and Delete Pages from this menu.

The Make View Program Editor can be accessed from this menu panel by clicking the Program
button. If you have a Related View in your project, the Home and Back buttons are available to

navigate between parent and child views.

1. From the Page Names panel, right click on the Page Name 1. The Pagename
window opens.

2. In the Page Name Field, type Personal Information.
3. Click OK. The page name appears in the list.

Page 1 of your View should look similar to this example:

Add Page
Insert Page
Delete Page

Program

éenhel

. Home Phone Number

--------- o i e
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Create a Code Table

There are four schools responding to the survey. To ensure accuracy and speed of data entry,
you are going to create a Code Table that links the information entered in the SchoolNum field
to the information in the PSNumber field. This means that each time a School ID Number is
selected from the drop-down, the field PS School Number will be automatically populated
based on the data table values you create. This helps to ensure consistency and eliminate errors
during data entry.

1.

6.

Right click on the text School ID Number to open the Field Definition dialog box.
*  PSNumber and SchoolNum must be Text type fields.
= PSNumber must be set to Read Only.

From the Code Tables section, select Codes. The Set Up Codes/Legal Links
dialog box opens.

Select PSNumber as the field you want to link to SchoolNum.
Click Create New. The Codes for Field box opens.

=  The schools are named A, B, C, and D. Based on the School ID Number selected, you
want the corresponding PS School Number to populate automatically.

On the first line enter 4. Tab over and type 723 as the PSNumber.

intc Set Up Code/Legal Links 1 x|

Codes for field: SchoolHum

SchoolMum PSNumber v DONOlSO";
A 123
B 234 OK
C 345
Z|D 456 Create Hew
*
Use Existing Table
Cancel

Use the tab key to navigate through the table set-up. Complete the seties as follows:

-19-
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= SchoolNum B and PSNumber 234
= SchoolNum C and PSNumber 345
= SchoolNum D and PSNumber 456
7. Select Do Not Sort.
8. Click OKin the Legal Links dialog box.
9. Click OKin the Field Definition dialog box.

= School ID Number # now contains a drop-down menu. Once you select a School
ID Number, the PS School Number will automatically populate with the value you
entered in the code table.
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Formatting Options

This section outlines ways to customize your workspace and to edit fields in your View. Try
changing the background color or altering the grid settings. Color changes will appear in the
Enter module.

Changing the Background Color

You can alter the background color of your Make View workspace and apply the changes to
one or all pages in your project.

= Select Format>Background. The Background dialog box opens.
* Click Change Color. The Color selection window opens.

= Select a new background color for your survey.

= (lick OK to accept the selected color.

= Select Apply to Current Page Only or Apply to All Pages.

® (lick OK to view your selection.

*  (lick Clear Color from the Background dialog box return to the default grey.

-21-
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Changing the Grid Settings
Grid settings give you a way to align the fields in the View. There are several ways to customize
your grid settings.

From the Make View navigation bar, click Format>Settings. The Snap to Grid dialog box
opens.

inic Snap to grid x|

Snap to arid Yisible arid on screen

[V Snhaptogrid on v Visible arid on

I3 ﬁ Character widths between grid lines

(" Snhap left side of prompt to grid

{+ Snap left side of entry field to arid

oK Cancel

The default setting of Snap to Grid is On. When moving a field on the View screen, the field
will snap to the left portion of the grid it is closest to. You have the option to snap based on
the prompt or the entry field. Select the Snap to Grid option if you want your fields to snap in
line with your grid when they are created or moved. De-selecting the Snap to Grid checkbox
allows you to move fields to any location on the page.

Select the Visible Grid option if you want your working space to contain a grid while designing
the View. The grid is not visible in the Enter module. Visible Grid on Screen, allows you to
remove the visible grid from the MakeView screen. If the checkmark is on, then you have the
option to change the width between the grid lines.

You can change the size of the grid spacing by using the up and down arrow keys next to
Character Widths Between Grid Lines. Changing the widths of the grid lines, gives you
more control over the spacing of fields.
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Resizing Fields

Entry fields can be resized.

Left click an entry field box (not the prompt text).

Use the blue bounding box and the click and drag method to make the data entry boxes
larger or smaller.

The numbers inside the fields tell you how many characters are visible in the survey.

To resize a drop-down box, press the Alt key and left click to get the blue bounding box
and resize using the blue bounding box handles.

Aligning Fields

Fields can be selected and aligned either horizontally or vertically.

Left click at the corner the field you want to align.

Hold your mouse button and drag a rectangle around several fields.

| |
| Zip Code [ |
. PS School # [ '
| '

Select Format>Alignment>Vertical or Format>Alignment>Horizontal. The selected
fields will line up based on your selection.

PSSchool # [ ZipCode [

-23-
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Copying and Pasting Fields

Fields can be cut, copied, and pasted.

Left click and drag a rectangle around the field you want to copy.

Select Edit>Copy.
*  Select Edit>Paste. The pasted field appears on top of the copied field.
= Left click and drag the field to move it.

* Right click the pasted field to open the Field Definition dialog box. Notice that a number
has been added to the Field Name since field names must be unique.
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Create Fields Part 2

Now you will create the asthma history section of the survey. The first question on the paper
survey is a series of yes or no checkboxes related to asthmatic conditions. You are going to
create one checkbox per condition and then group all the conditions. This will allow you to
analyze how many students checked Yes per condition and to analyze the conditions as a group.
A single checkbox will indicate a yes if checked and a no if blank. To create the next section of
the survey, you will need to create separate fields for the question and the checkboxes.

Questions have been shortened in the electronic survey; refer to Appendix: B Parent S chool Asthma
Pre-Intervention Survey to see the original questions.

You are not going to create the entire survey in Lesson 1; however, you can use the field
information in the Appendix A: Code Sheet for additional practice.

Add a New Page
1. From the Page Names panel, click Add Page. The new page appears.

2. Right click inside your new page. The Field Definition dialog box opens.

3. Enter the following Prompt: Has a health professional ever told you that your child has any
of the following conditions?

» For long questions, you may need to enter a line break inside your prompt. To
do this, hold the Ctrl key and press Enter inside the sentence where you want
the break to occut.

4. Sclect Label/Title as your Variable Type.
5. Type the Field Name: Condition.

6. Click OK

Create a Checkbox

1. Under the question, right click to open the Field Definition dialog box.
2. Enter the following Prompt: Asthmza.

3. Select a Variable Type of CheckBox.

4. Use the default Field Name, Asthma.

5. Click OK. The Asthma checkbox appears in your view.

* In the Enter Data module, checkboxes appear as selected or not selected.

- 25.
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* In the Data Table, checkboxes ate stored as -1 and 0.

= When used in Analysis Commands, checkbox values are selected and coded as

(+) and ().

# Practice

Create three checkboxes to complete the question.

Arrange the checkboxes near each other and align them horizontally or vertically, depending
on your workspace and preference.

Prompt/Question Variable Type | Field Name | Other
Reactive Airway Disease Checkbox RAD

Asthmatic Bronchitis or Checkbox Bronchitis

Wheezy Bronchitis

Wheezing Checkbox Wheezing

Your checkboxes should look similar to this example:

i 'Hé's' a i{ééiﬂi 'bkéfé.é.&ib}iéf 'e'\}i:'r' i&l& You ii.& ;b’i{r' 'c};{la' };s;;.; '9? the ?&il’bi{.}ig'{:&iﬁ 1’.6&"&3 e N N




Create a Group

LESSON 1

Groups can be created to organize similar data on a survey. Variables that are part of a group
can be analyzed alone or as patt of the group. Take the question and the variables regarding

conditions and group them.

1. Use the left mouse button to drag a rectangle around the fields that are to be
included in the group. This includes the question and the four variables.

2. From the navigation menu select Insert>Group. The Group Dialog box opens.
3. In the Group Description field, type Asthmatic Conditions.

* To select a different color for the group, click Set Color.

Group Description

|&sthmatic Conditions]

—

Set Color

oK

LCancel

4. C(lick the OK.

» To Edit or Ungroup, right click inside the group name. The Edit Group dialog opens.

* To Resize the box containing the group, double click inside the box. A resize arrow

appears.

= To move the entire group, left click the group title text, hold, and drag to the new

location.
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Create a Mirror Field

Mirror fields allow you to show one field on many pages, but only enter the information once.
Because there are several pages of information for each child, you want to place their Student
ID on each page.

1. Open the Field Definition dialog box.

2. Enter the Prompt as ID.

3. Select the Variable Type: Mirror.

4. Use the default Field Name, ID.

5. Click OK The Assign Variable to Mirror Field dialog box opens.

6. Sclect the variable StudentID from the list.

7. Click OK.

8. Move the field to the top of the page.

» In the Enter Data module, once the Student ID # field is entered, it will
populate this field automatically.



LESSON 1

Create a Yes/No Field

1.

2.

Open the Field Definition dialog box.

Enter the following Prompt: Has a health professional prescribed any medication to your
child for breathing problems?

» The original question has been modified as it contained more than 128
characters, which is more than allowed in the prompt field.

Select the Variable Type: Yes/No.
Type the Field Name: Medication.
Click OK.

= From the Enter Data module, only the text Yes or No can be entered in this
field.

» In the Data Table Yes/No values ate stored as 1 or 0. Missing values appear
blank.

»  When used in Analysis Commands, Yes/No values are selected and coded as
(+) and (-). Missing values are selected and coded as (.).
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# Practice

Create a new type of drop-down selection box called Comment Legal.

= Comment Legal fields are set up like Legal Value fields, except that Comment Legal fields
allow you to place a number in front of text, so that, when populating fields, a number is
entered. This is a text field, but it will display as a number in the Analysis module.

Create a group that contains the variable Symptoms, Whistle, and Cough. Name the group

Monthly Breathing Difficulties.

Name Page 2 _Asthma Symptoms.

Prompt/Question Variable Type | Field Name | Other

Select the month when your | Text WMonth Click Comment

child's breathing was the Legal. Create a New

WOrSt. Table.
Enter each month of
the year in the
following format:
1-January 2-
February 3- March,
4- April, 5- May, 6-
June, 7- July, 8-
August, 9-
September, 10
October, 11-
November, 12-
December
Select Do Not Sort.

During their worst breathing | Label/Title Symptoms

month, select how often the

following symptoms

occutred.

Wheeze or whistling in the Text Whistle Legal Value

chest?
The 5 Values are:
Never
2 times each week or
less

3 to 6 times each
week

Every day, but not all
day




LESSON 1

Prompt/Question Variable Type | Field Name | Other
Every day and all day
Select the Do No
Sort Checkbox.
Have a cough? Text Cough Legal value

You can use an
existing LLegal Value
table to populate new
tables. From the Field
Definition dialog box,
click Legal Values.

From the Set Up
Code/Legal Links
dialog box, click Use
Existing Table. The
Select a View dialog
box opens.

Select codeWhistle.
Click OK. The Select
a Field to Link dialog
box opens.

Select Whistle. Click
OK. The Legal
Values for Cough
populate.

Select the Do Not
Sort checkbox. Click
OK
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Page 2 of your View should look similar to this example:

elnterventionSurvey Page:2




Skills Review

Add a Page to the View.

Create a numeric variable to hold the number of missed school days.

LESSON 1

The survey asks respondents if they have missed sports activities. The variable MissSport is a
Yes/No variable. Create a Legal Value variable that asks for more information if the respondent
answers Yes. Align the question to the MissSport variable.

Create a numeric variable to hold the number of people living in the home with asthma.

Verify the tab order for all your pages. You want your cursor to follow a logical data entry path.

Name Page Three Medical Information.

Select File>Save. Epi Info™ saves your data automatically, but it is a good idea to save after

you add new information.

Prompt/Question Variable Type | Field Name | Other

How many days of school has | Number MissDays Pattern ###

your child missed due to

breathing problems?

Have breathing problems Yes/No MissSport

stopped your child from

participating in sports?

If Yes, how many times in the | Text SPTimes Legal Value

past month.
2 times a month or
fewer
3 to 4 times a month
1 to 3 times each week
4 times each week or
more
Select Do Not Sort

How many people living in Number IMHome Ht

your home, including this

child, have asthma?
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Page 3 of your View should look similar to this example:

9 [m] B3] |7 Make /Edit Yiew:PreInterventionSurvey

1 Personal Information | File Edit View Insert Format Tools Help

2 Asthma Symptoms
3 Medical Information

Add Page
Insert Page
Delete Page

i i i
.................

i '

‘

this.child, have asthma? [ | |

living in your

|___How many people.

NOTE

If you need to close Epi Info™ before completing your survey, the New Data Table
dialog box will appear and prompt you to create a Data Table. Click Cancel. You
do not want to create a data table until you are ready to enter data.

= When you exit either by going to File>Exit or clicking the close X, the New
Data Table dialog box opens.

= (lick Cancel.

= If your data table is set before you are ready to enter data, you can use
Tools>Delete Data Table to reset your View. This will allow you to make
edits to your field names and add code tables.

WARNING: This function should only be used if you have not entered any
data; otherwise, all your data will be deleted!



Lesson Complete!

WHAT YOU LEARNED

LESSON 1

How to
* Navigate Make View.

= Create a new project.

= Use the Field Definition dialog box to create fields.

® Add pages to a View.

"= Customize a View.
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